八月 5th, 2017

这次处理的问题是网友提供的服务器环境中安装的WDCP环境,但是不知他操作什么了,导致php -v和phpinfo文件看到两个不同的PHP版本,然后导致在php.ini安装的组件需要运行并非在当前WEB环境中运行。我们需要将其中一个PHP版本限制掉只使用一个PHP版本。

在操作之前一定要先备份好数据,万一有不测风云我们还可以去恢复数据。

第一、查看当前php.ini

这里可以看到有3个php.ini文件,默认php -v看到的是/etc/php.ini配置PHP版本,而站点是用到PHP5.6.30版本。

第二、添加变量默认php版本

vi /etc/profile

原本我们需要删除不准备启用的PHP版本文件的,担心删除错了锁定不删除,反正默认过去后不影响,这里我们需要在profile文件中默认指定PHP版本。

export PATH=”/www/wdlinux/apache_php-5.6.30/bin:$PATH”

添加变量默认php版本

这里要指定当前PHP全局是5.6.30版本,所以添加上面脚本。

source /etc/profile

然后执行命令看是否有报错,没报错就OK。

解决服务器环境2个PHP版本不统一问题 php -v和phpinfo不同版本

这里可以看到php -v和phpinfo是一样的PHP版本,问题可以得到解决。

 

Comments are closed.